TeamViewer versions before 15.83 open to code-execution risk

Pakistan’s National CERT says a high-severity TeamViewer flaw (CVE-2026-111585, CVSS 8.8) needs an urgent upgrade to version 15.83 or later.

National CERT has issued a TeamViewer security alert over high-severity CVE-2026-111585 (CVSS 8.8).

The flaw stems from an integer overflow in remote-control screen data and may allow crashes or code execution.

Clients earlier than 15.83 on Windows, Linux and macOS are affected; Portable and some Android builds are too.

Fixed releases are 15.83 or later, or legacy builds 14.7.48868 and 13.2.36231.

Exploitation needs an active remote session with an attacker-controlled or compromised host.

Read the full story

Zaviya News